Invoicing Services - iOS
Incident Report for Invoice Simple
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 09:53 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 09:42 PST
Identified
The issue has been identified and a fix is being implemented.

We can also confirm that clicking on "Restore Purchases" under the App Settings fixes the degraded performance issues for affected users.
Posted Nov 14, 2024 - 14:10 PST
Update
We are continuing to investigate this issue. Affected users might be seeing better performance by going on their Settings page and clicking on "Restore Purchases".
Posted Nov 14, 2024 - 11:13 PST
Investigating
We're currently investigating an issue with our invoicing services on iOS. Affected users might be experiencing problems logging in, accessing their invoices or managing their subscriptions.
Posted Nov 14, 2024 - 10:48 PST
This incident affected: Invoice service.